FonoSIP.com
lang world mobile site

Cisco Cisco CallManager Express example configuration

Tags: Cisco CME Cisco CallManager Express Cisco Unity Express Configuration Cisco-SIPGateway/IOS-12.x Configuring SIP MWI Cisco 2811 FXO

Example Config

voice service voip
 allow-connections sip to sip
 sip
  header-passing
  registrar server expires max 600 min 120
!
voice class codec 1
 codec preference 1 g729r8
 codec preference 2 g711ulaw
!
voice translation-rule 5
 rule 1 /^9\(.......\)/ /\1/
!
voice translation-profile SIP
 translate called 5
!
interface Serial0/0
 ip address 60.100.100.200 255.255.255.252
 ip nat outside
!
interface FastEthernet0/1.7
 description Corporate User VLAN 7
 encapsulation dot1Q 7
 ip address 10.10.7.254 255.255.255.0
 ip nat inside
!
ip nat inside source list NAT interface Serial0/0 overload
!
ip access-list extended NAT
 deny  ip 10.10.7.0 0.0.0.255 10.10.5.0 0.0.0.255
 deny  ip 10.10.6.0 0.0.0.255 any
 permit ip 10.10.7.0 0.0.0.255 any
!
dial-peer voice 300 voip
 description dial 9 for outside SIP local call
 translation-profile outgoing SIP
 destination-pattern 9T
 voice-class codec 1
 session protocol sipv2
 session target sip-server
 dtmf-relay rtp-nte
 no vad
!
dial-peer voice 400 voip
 description test incoming sip to 812345
 session protocol sipv2
 session target sip-server
 incoming called-number 812345
 dtmf-relay sip-notify
 no vad
!
sip-ua
 credentials username 812345 password 021AAA0A05015F711D realm fonosip.com
 authentication username 812345 password 55181AAA2F4B1E5948
 no remote-party-id
 retry invite 2
 retry register 10
 timers connect 100
 registrar ipv4:fonosip.com expires 3600
 sip-server ipv4:fonosip.com:5060
 notify telephone-event max-duration 500
!
telephony-service
 max-ephones 3
 max-dn 3
 ip source-address 60.100.100.200 port 2000
 auto assign 1 to 3
 create cnf-files version-stamp Jan 01 2002 00:00:00
 max-conferences 4 gain -6
 transfer-system full-consult
!
!
ephone-dn  3
 number 812345
!
!
ephone  1
 mac-address 0033.2027.48D7
 type CIPC
 button  3:3
!


See also Cisco Auto QOS

-- FonoSIP.com -- Search Site -- About Us -- Add Credit -- Mobile Site -- Login -- Service Numbers -- Help -- Swag -- Write to us info@fonosip.com -- Voicemail 1-360-226-7665 -- FonoSIP.com © 2010

Powered by BA.net iGames


FonoSIP.com supports Xten / Counterpath SIP softphones for Windows, Mac, iPhone and Linux. Internet telephony equipment such as Linksys PAP2, Cisco, Sipura, Nokia N71. Apple iPhone, iPod Touch, iPad. Android. Codec G729. Fring Mobile. Bring your Own Device BYOD. We also support SIP Trunking, replace your phone lines. Asterisk PBX, TrixBox.